Tuesday, May 01, 2007

Mimetypes not working for you in KDE4?

If KDE4 mimetypes aren't working, type "kbuildsycoca4" instead of "kbuildsycoca". I believe this change allows for KDE3 and KDE4 apps to coexist. I thought I'd share this since it took me an embarrassingly long amount of time to figure it out :)

I also recall someone saying that the "shared-mime-info" package had to be a certain version. So I found a Fedora RPM for 0.17 and upgraded to that (I know that RPM is old but it was the only one I could find quickly). Not sure if it was required though.

3 comments:

Seb Ruiz said...

If you get some crashes, you might also need to do:
 `unset XDG_DATA_DIRS`
before running kbuildsycoca4

pinotree said...

The 0.17 version of shared-mime-info is not enough indeed. You need some version >= 0.18, although most recent is better.
This reminds me I should change the cmake check to result in an error instead of a simple message if the version is not enough.

Administrator said...

Get in touch with us for assignment help all the students who are in trouble due to their tough writing assignments.